Get in touch
Back
Degraded

Outbound Email Service Disruption

Started 10 Apr at 01:27am GMT+6, resolved 11 Apr at 02:04am GMT+6.

API
Resolved

The issue affecting our outbound email service has been fully resolved.

Posted 11 Apr at 02:04am GMT+6.
Updated

We’ve identified and fixed the edge case that caused the disruption. Our team is actively working to resume the service, and we’ll keep you updated on progress.

Posted 10 Apr at 01:58am GMT+6.
Updated

We've identified the root cause. A trial user exploited an edge case in our system to send a large number of emails via the message-forwarding feature. As a result, our outbound email channel was automatically paused by our provider to maintain deliverability standards.


Impact:
- Outbound emails from ThriveDesk are temporarily delayed.
- Customers may experience interruptions in sending conversations or receiving email notifications.

Posted 10 Apr at 01:37am GMT+6.
Created

We identified unusual outbound email activity originating from a newly created trial account. This activity triggered a temporary pause from our email service provider due to a high volume of bounced messages.

Posted 10 Apr at 01:27am GMT+6.