
Scheduled Maintenance
Started 3 May at 10:00am GMT+6, resolved 3 May at 01:45pm GMT+6.
Resolved
Maintenance Completed – All Systems Operational

Created
Scheduled Maintenance Notification
Status: Scheduled Maintenance
Start Time: Saturday, May 3, 2025 – 12:00 AM EST
End Time: Saturday, May 3, 2025 – 4:00 AM EST
Duration: 4 hours
Impact: Partial service downtime
Details:
We will be performing scheduled maintenance to upgrade our hardware and improve server performance and reliability. During this window, the system will be temporarily unavailable for sending or replying to support tickets.
What’s Not Affected:
All incoming emails will be securely received and stored.
No changes will be made to email storage hardware.
What’s Affected:
- Ticket sending and replying functionality will be unavailable during the maintenance window.
Why this matters:
These upgrades will enhance performance, ensure better scalability, and improve your overall experience with ThriveDesk.
We apologize for any inconvenience this may cause and appreciate your patience as we work to improve our services.